MVR Screenings Are Delayed
Incident Report for Checkr
Resolved
This issue has been resolved and MVR screenings are completing within expected timeframes. Please reach out to Checkr Customer Support if you have any additional questions!
Posted Dec 18, 2020 - 21:55 UTC
Monitoring
We have discovered the source of the issue and a fix has been implemented. We're continuing to observe logging to ensure turnaround time is returning to expected timeframes.
Posted Dec 18, 2020 - 20:42 UTC
Investigating
We are currently investigating an upstream issue that is delaying the completion of MVR screenings. Screenings ordered after 11:30 AM PT today are currently impacted. We'll provide an update shortly!
Posted Dec 18, 2020 - 20:32 UTC
This incident affected: API and Webhooks.