Document Uploads Experiencing Issues
Incident Report for Checkr
Resolved
Our service provider has resolved the issue on their end. Candidates should now be able to upload documents successfully. Please reach out to Checkr Customer Support if you run into any other issues!
Posted Feb 10, 2021 - 23:05 UTC
Update
We are still monitoring the situation with our service provider. The ability to upload documents is still unavailable at this time. Our team is working to provide a notification to candidates in the Candidate Portal to alert them of the issue.
Posted Feb 10, 2021 - 21:47 UTC
Identified
Due to an upstream service outage, candidates are unable to successfully upload documents to Checkr. Our team is monitoring the situation and we will provide updates as we receive them from our service provider.
Posted Feb 10, 2021 - 20:59 UTC
This incident affected: Apply page and Candidate Portal.