Dashboard reports loading slowly
Incident Report for Checkr
Resolved
System has recovered and is functioning properly once again
Posted May 17, 2023 - 18:17 UTC
Monitoring
After investigating, systems appear to be loading reports quickly as expected. We are currently monitoring for anomalies.
Posted May 17, 2023 - 16:26 UTC
Investigating
Engineering is actively investigating this issue.
Posted May 17, 2023 - 15:39 UTC
This incident affected: Client Dashboard.