Intermittent errors across the Checkr Candidate Dashboard
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Apr 29, 2023 - 00:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2023 - 23:37 UTC
Investigating
We are currently investigating this issue.
Posted Apr 28, 2023 - 23:08 UTC
This incident affected: Candidate Portal.