Unable to Access Candidate Portal

Incident Report for Checkr

Resolved

This incident has been resolved. Please contact clients@checkr.com if you are still encountering issues.
Posted Jul 01, 2020 - 23:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2020 - 22:40 UTC

Investigating

Candidates are currently unable to access the candidate portal, we're looking into it now.
Posted Jul 01, 2020 - 22:19 UTC
This incident affected: Candidate Portal.