Delay in report completion
Incident Report for Checkr
Resolved
This incident has been resolved and report completion time has returned to normal.
Posted May 13, 2022 - 19:10 UTC
Monitoring
A fix has been implemented and we are seeing report completion times return towards normal. We are continuing to monitor results.
Posted May 13, 2022 - 17:35 UTC
Investigating
Reports containing a national criminal search are taking longer than usual to complete. We are investigating this issue.
Posted May 13, 2022 - 17:18 UTC
This incident affected: Data Source.