Some services are experiencing degradation due to the continuing AWS outage

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:54 UTC

Monitoring

Monitoring Checkr services
Posted Oct 20, 2025 - 15:30 UTC
This incident affected: API, Webhooks, Apply page, Candidate Portal, Client Dashboard, and Data Source.