Issue With Upstream Provider
Incident Report for Checkr
Resolved
Locations screenings should now be generating as expected. Please contact Checkr Customer Support if you need any additional support!
Posted Nov 11, 2020 - 17:29 UTC
Monitoring
Our upstream provider has informed us that they have stabilized their service. We're continuing to monitor the apply page reliability to ensure it's been resolved.
Posted Nov 11, 2020 - 17:21 UTC
Investigating
One of our upstream providers is currently experiencing an issue that is affecting our ability to generate screening locations for our Health Screenings product. We'll be back with an update shortly.
Posted Nov 11, 2020 - 17:10 UTC
This incident affected: Apply page.