We're experiencing degraded performance on our Dashboard Search
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 18, 2019 - 00:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Sep 17, 2019 - 23:23 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 17, 2019 - 22:46 UTC
This incident affected: API and Dashboard.