Checkr dashboard and API performance issues
Incident Report for Checkr
Resolved
This incident has been resolved. Performance is back to normal.
Posted May 18, 2022 - 21:39 UTC
Update
We are continuing to work on this issue. API and dashboard performance are improving.
Posted May 18, 2022 - 20:02 UTC
Update
We are continuing to work on this issue.
Posted May 18, 2022 - 18:19 UTC
Update
We're seeing another uptick in performance issues. We're monitoring and continuing to work toward a resolution.
Posted May 18, 2022 - 16:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Checkr Dashboard and API should be up and running for all users.
Posted May 18, 2022 - 16:21 UTC
Identified
The Checkr dashboard and API are experiencing delays. We have identified the source of the issue and are working on a fix.
Posted May 18, 2022 - 15:50 UTC
This incident affected: API, Webhooks, Apply page, Candidate Portal, Client Dashboard, and Partner Dashboard.