Ordering Reports Through Dashboard Not Working
Incident Report for Checkr
Resolved
We've deployed a fix for this issue and are confident that the issue is now resolved! 🎉

Please contact Checkr Customer Support if you're still encountering issues!
Posted Dec 04, 2020 - 18:55 UTC
Update
We're preparing to deploy a fix for this issue! We'll be back with an update shortly.
Posted Dec 04, 2020 - 18:41 UTC
Identified
We've located the root cause of the issue and are working on a fix now.
Posted Dec 04, 2020 - 18:20 UTC
Investigating
We are currently investigating reports of some users being unable to order reports through the dashboard. We're looking into a fix right now and we'll be back with an update soon.
Posted Dec 04, 2020 - 18:11 UTC
This incident affected: Client Dashboard.