Report completion delay
Incident Report for Checkr
Resolved
Report processing is back to normal.
Posted almost 2 years ago. Jun 09, 2017 - 16:41 UTC
Investigating
We are investigating an issue that is preventing reports from completing.
Posted almost 2 years ago. Jun 09, 2017 - 15:20 UTC