Unable to Adjudicate Reports with Credit Screenings
Incident Report for Checkr
Resolved
This issue has now been resolved!
Posted Apr 29, 2021 - 21:15 UTC
Identified
We are aware of an issue impacting the ability of people to adjudicate reports which include Credit screenings. We'll provide an update once the issue is resolved!
Posted Apr 29, 2021 - 20:29 UTC
This incident affected: Client Dashboard.