Slight increase in turnaround time for some reports
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 22:05 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2023 - 20:39 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2023 - 19:07 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2023 - 19:06 UTC
Investigating
We are currently investigating this issue.
Posted Jul 14, 2023 - 19:02 UTC
This incident affected: Data Source.