Delayed Background checks
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 24 days ago. Aug 28, 2019 - 20:31 UTC
Investigating
Some types of background checks are taking longer to complete
Posted 24 days ago. Aug 28, 2019 - 20:07 UTC
This incident affected: API.