Candidate Creation Experiencing High Latency
Incident Report for Checkr
Resolved
We identified the issue and have confirmed that latency is back to acceptable levels.
Posted Sep 22, 2020 - 17:01 UTC
Investigating
We're currently investigating higher than usual latency for candidate creation.
Posted Sep 22, 2020 - 16:43 UTC
This incident affected: API and Client Dashboard.