Health screening passes are not being delivered
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 19:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2024 - 10:59 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2024 - 01:18 UTC
Investigating
Candidates are currently not receiving health screening passes that need to be delivered to the lab to complete the screening.

Some labs may be able to complete the screening still, but they will have to direct the lab to look up their name.
Posted Sep 25, 2024 - 23:35 UTC
This incident affected: Candidate Portal.