Candidates are unable to complete Identify Verifications for international background checks due to a vendor outage

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted May 11, 2026 - 02:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 01:29 UTC

Investigating

International reports that include these checks will be delayed.
Posted May 10, 2026 - 21:21 UTC
This incident affected: Apply page and Data Source.