Impacted Candidate Visibility
Incident Report for Checkr
Resolved
Users should now be able to view and search for candidates without issue.
Posted May 04, 2020 - 21:33 UTC
Identified
We've identified the issue and are taking action to resolve it now.
Posted May 04, 2020 - 21:25 UTC
Investigating
We are currently investigating an issue that is impacting the visibility of candidates within the dashboard.
Posted May 04, 2020 - 21:18 UTC
This incident affected: Client Dashboard.