High latency on API reports endpoint

Incident Report for Checkr

Resolved

Incident has been resolved.
Posted Aug 23, 2025 - 00:21 UTC

Update

We are continuing to investigate this issue
Posted Aug 22, 2025 - 22:57 UTC

Investigating

We are currently investigating this issue
Posted Aug 22, 2025 - 21:51 UTC
This incident affected: API.