Payments and invoicing outage.
Incident Report for Checkr
Resolved
The incident is resolved.
Posted 11 months ago. Nov 19, 2018 - 22:31 UTC
Update
We are continuing to work on a fix for this issue.
Posted 11 months ago. Nov 19, 2018 - 21:23 UTC
Update
Systems are now operational.
Posted 11 months ago. Nov 19, 2018 - 21:23 UTC
Update
We are continuing to work on a fix for this issue.
Posted 11 months ago. Nov 19, 2018 - 20:59 UTC
Identified
Update: Applicant pay, customer invoices, and Continuous Check new subscriptions are temporarily unavailable. The issue has been identified and we are working to resolve it.
Posted 11 months ago. Nov 19, 2018 - 20:22 UTC
This incident affected: API, Dashboard, and Apply page.