Increased failure rate loading reports in the Dashboard

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 00:22 UTC

Monitoring

We identified an increased failure rate when accessing reports via the dashboard. A fix has been implemented and we are currently monitoring the results.
Posted Aug 12, 2026 - 22:38 UTC
This incident affected: Client Dashboard.