Some reports inaccessible through the Dashboard
Incident Report for Checkr
Resolved
A fix has been deployed and we're monitoring traffic to ensure everything is working as expected. Please reach out to clients@checkr.com if you notice any other issues!
Posted Sep 04, 2020 - 22:40 UTC
Investigating
We're currently aware of an issue impacting the visibility of some reports on the dashboard. Our team is looking into it right now! We'll provide an update shortly.
Posted Sep 04, 2020 - 22:32 UTC
This incident affected: Client Dashboard.