Dashboard outage
Incident Report for Checkr
Resolved
The issue has been resolved. Please contact support if you have any issues.
Posted about 1 year ago. Nov 21, 2017 - 19:01 UTC
Investigating
The Dashboard is returning 502 errors. Engineers are investigating.
Posted about 1 year ago. Nov 21, 2017 - 18:54 UTC