Some reports are delayed
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 16:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2021 - 01:54 UTC
Identified
The issue has been identified and a fix is being worked on.
Posted Apr 10, 2021 - 00:45 UTC
Investigating
We are investigation an issue with a criminal records data vendor.
Posted Apr 10, 2021 - 00:43 UTC
This incident affected: Data Source.