API latency affecting delayed completion for reports with Credit Checks
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 22:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2023 - 22:23 UTC
This incident affected: Client Dashboard.