Increased turnaround time for a subset of reports

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 20:31 UTC

Investigating

We are currently investigating this issue.
Posted Feb 26, 2025 - 19:46 UTC
This incident affected: Data Source.