Some reports experiencing longer turn around times
Incident Report for Checkr
Resolved
We have found the root cause of the issue and reports are beginning to complete as expected. Reports created on, or after, 8/27 should not be impacted. Please reach out to Checkr Customer Support with any additional questions or concerns.
Posted Aug 28, 2021 - 23:26 UTC
Investigating
Customers may experience longer report turn around times due to the delayed completion of some Global Watch List, National Criminal, County Criminal and Sex Offender searches beginning on 8/26. We are actively working on this issue and will provide an update once more information is available.
Posted Aug 28, 2021 - 21:41 UTC
This incident affected: Data Source.