Increased API latency
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 00:46 UTC
Identified
While we are seeing recovery of our systems, we are still experiencing delays with the processing of some screenings and reports, including MVR. We are continuing to work through the backlog of requests.
Posted Mar 01, 2022 - 00:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2022 - 00:08 UTC
Investigating
We are currently investigating this issue.
Posted Feb 28, 2022 - 23:39 UTC
This incident affected: API and Client Dashboard.