Dashboard
Incident Report for Checkr
Resolved
The dashboard is now loading as expected. If you're still seeing the "blank" page, try to clear your browser's cache and reload the page.
Posted Feb 20, 2020 - 23:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2020 - 23:29 UTC
Investigating
We have identified that users may be receiving a "blank" page upon loading the dashboard. Our team is looking into this now.
Posted Feb 20, 2020 - 23:18 UTC
This incident affected: Client Dashboard.