Checkr Staging Dashboard is experiencing loading issues

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted May 05, 2023 - 04:27 UTC

Monitoring

We've identified and implemented a fix to DNS in the cluster and are monitoring recovery.
Posted May 05, 2023 - 02:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 04, 2023 - 22:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2023 - 18:02 UTC

Investigating

We are currently investigating this issue.
Posted May 04, 2023 - 14:45 UTC