Candidates may experience issues viewing the clinic map when selecting a screening location
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Jun 28, 2023 - 23:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2023 - 22:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 28, 2023 - 20:48 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 28, 2023 - 19:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 28, 2023 - 18:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 28, 2023 - 17:47 UTC
Investigating
We are currently investigating this issue.
Posted Jun 28, 2023 - 17:44 UTC
This incident affected: Apply page.