Delays in TAT on MVR reports

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted Aug 22, 2022 - 23:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2022 - 22:31 UTC

Update

We are continuing to investigate this issue.
Posted Aug 22, 2022 - 21:42 UTC

Update

We are continuing to investigate this issue.
Posted Aug 22, 2022 - 20:42 UTC

Update

We are continuing to investigate this issue.
Posted Aug 22, 2022 - 19:41 UTC

Investigating

We are currently investigating this issue.
Posted Aug 22, 2022 - 18:00 UTC
This incident affected: Data Source.