We're experiencing increased latency on our API
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2019 - 19:53 UTC
Monitoring
We have identified the issue and are monitoring traffic.
Posted 21 days ago. Sep 27, 2019 - 19:40 UTC
Investigating
We are currently investigating this issue.
Posted 21 days ago. Sep 27, 2019 - 15:34 UTC
This incident affected: API and Dashboard.