Elevated turnaround times for Federal Criminal Searches

Incident Report for Checkr

Resolved

Resolved- the maintenance window has ended and normal search operations have resumed.
Posted Aug 16, 2026 - 20:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 16, 2026 - 18:33 UTC

Monitoring

Elevated turnaround times for Federal Criminal searches are related to scheduled PACER maintenance from 5:00 AM to 4:00 PM ET today. Some searches may continue to experience delays as processing catches up following the maintenance window.
Posted Aug 16, 2026 - 12:36 UTC

Investigating

We are currently investigating this issue.
Posted Aug 16, 2026 - 12:05 UTC
This incident affected: Data Source.