Delays in MS TAT on MVR reports

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 19:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 23:00 UTC

Investigating

We are currently investigating this issue.
Posted Feb 25, 2025 - 21:00 UTC
This incident affected: Data Source.