MVR Screenings Are Delayed
Incident Report for Checkr
Resolved
This issue has been resolved. Please reach out to our Customer Support team if you have any additional questions or concerns!
Posted Apr 17, 2021 - 01:01 UTC
Monitoring
A fix is in place and we're starting to see reports complete. We're continuing to work on any outliers and will update when we've completely resolved the issue.
Posted Apr 16, 2021 - 23:06 UTC
Update
We are still working on a fix for this issue. We'll provide another update shortly.
Posted Apr 16, 2021 - 22:32 UTC
Identified
We've identified the root cause of the issue and we working on implementing a fix.
Posted Apr 16, 2021 - 21:48 UTC
Investigating
At this time, reports with MVR screenings may not be completing. Our team is investigating the issue and we'll provide an update when we've identified the issue.
Posted Apr 16, 2021 - 21:34 UTC
This incident affected: Data Source.