We're experiencing an outage with our Dashboard
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 19:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2020 - 19:48 UTC
Investigating
We are currently investigating this issue.
Posted Feb 11, 2020 - 19:30 UTC
This incident affected: Dashboard.