Our cloud provider is experiencing intermittent network errors
Incident Report for Checkr
Resolved
Network traffic appears to have returned to normal
Posted 28 days ago. Jun 24, 2019 - 13:08 UTC
Investigating
We are currently investigating this issue.
Posted 28 days ago. Jun 24, 2019 - 12:34 UTC
This incident affected: API, Webhooks, Dashboard, and Apply page.