Reports Not Loading on Dashboard
Incident Report for Checkr
Resolved
This issue has been resolved, however, a hard refresh (clearing your browser cache) may be needed to load dashboard content. As always, please feel free to contact Customer Support if you have any questions or concerns!
Posted Sep 09, 2020 - 21:12 UTC
Monitoring
We're looking into instances where reports are not loading on the dashboard. While we believe this issue has already been resolved, we're continuing to monitor just to be sure. Please attempt to clear your browser cache or utilize a new browser if you're still seeing the issue. Please contact clients@checkr.com if the issue persists!
Posted Sep 09, 2020 - 20:50 UTC
This incident affected: Client Dashboard.