Reports Delayed
Incident Report for Checkr
Resolved
This issue has been resolved and reports should be completed as expected.
Posted Sep 02, 2021 - 23:57 UTC
Monitoring
We have implemented a fix and report delays are beginning to shrink. We will be monitoring the turn around time for a little while longer to confirm this has resolved the issue.
Posted Sep 02, 2021 - 23:36 UTC
Update
We are still investigating this issue. We'll provide another update soon.
Posted Sep 02, 2021 - 22:29 UTC
Investigating
We are looking into delays affecting some reports. We'll provide an update shortly.
Posted Sep 02, 2021 - 20:50 UTC
This incident affected: Data Source.