Increased turnaround time for Federal searches due to a vendor outage
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 15:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2024 - 18:30 UTC
Investigating
We are currently investigating this issue.
Posted Nov 24, 2024 - 17:56 UTC
This incident affected: Data Source.