Email & Text Message Delays
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 26 days ago. Aug 27, 2019 - 16:06 UTC
Investigating
We’re currently investigating delayed email and text message notifications.
Posted 26 days ago. Aug 27, 2019 - 14:18 UTC
This incident affected: API and Apply page.