Delays in reports completing in the Checkr Staging Dashboard
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 23:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2022 - 22:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 16, 2022 - 22:51 UTC
This incident affected: Client Dashboard and Data Source.