Rapidcourt Federal Criminal Searches Delayed
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Mar 24, 2024 - 02:40 UTC
Update
We are continuing to monitor report completion for federal criminal searches (Rapidcourt).
Posted Mar 24, 2024 - 01:58 UTC
Monitoring
Responses returning as of 15 minutes ago.
Posted Mar 24, 2024 - 01:49 UTC
Investigating
Starting around 5:45PM (ET), federal criminal searches experienced a temporary delay in report completion. Our engineers are actively investigating this issue.
Posted Mar 24, 2024 - 01:46 UTC
This incident affected: Data Source.