We are experiencing minor delays in PDF generation for a small subset of reports

Incident Report for Checkr

Resolved

This incident has been resolved.
Posted May 06, 2026 - 16:44 UTC

Investigating

We are actively addressing the issue
Posted May 06, 2026 - 15:54 UTC
This incident affected: Client Dashboard.