Network Issues
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 21:42 UTC
Investigating
We are currently investigating network issues that are affecting all systems.
Posted Jul 17, 2020 - 21:24 UTC
This incident affected: API, Webhooks, Apply page, Candidate Portal, and Client Dashboard.