Candidates Not Appearing on Dashboard
Incident Report for Checkr
Resolved
This issue appears to be fully resolved now! Please email clients@checkr.com for additional support!
Posted Jun 11, 2020 - 21:11 UTC
Monitoring
Our team has implemented a fix and the issue appears to be resolved. If you're still unable to view candidates, please attempt to log in/out of Checkr and clear your cache as well.
Posted Jun 11, 2020 - 21:01 UTC
Investigating
We're aware of an issue impacting the visibility of candidates on the dashboard and are looking into it now!
Posted Jun 11, 2020 - 20:53 UTC
This incident affected: Client Dashboard.