Increased turn around time on portion of reports with SSN traces and Criminal screenings
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted May 11, 2024 - 21:44 UTC
Update
We are continuing to monitor for any further issues.
Posted May 11, 2024 - 02:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2024 - 22:52 UTC
This incident affected: Client Dashboard and Data Source.