Candidates rendering issues in our dashboard
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 20, 2018 - 03:12 UTC
Identified
Our candidate search is now returning partial results. We are working on recovering the rest.
Posted 3 months ago. Sep 19, 2018 - 22:10 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Sep 19, 2018 - 21:44 UTC
This incident affected: Dashboard.